Commit a1dc3d36 authored by Mab's avatar Mab

Merge branch 'ccomptes/features/various' into ccomptes/develop

parents 096928e4 57c77257
......@@ -8,53 +8,37 @@ module.exports = {
},
stages: [
{
title: 'Upload',
type: 'upload',
title: 'Rédaction',
type: 'edit',
},
{
title: 'File Prep',
type: 'file_prep',
title: 'Relecture CR',
type: 'review',
},
{
title: 'Edit',
type: 'edit',
title: 'Relecture PS',
type: 'review',
},
{
title: 'Review',
title: 'Relecture PC',
type: 'review',
},
{
title: 'Clean Up',
title: 'Greffe',
type: 'clean_up',
},
{
title: 'Page Check',
type: 'page_check',
},
{
title: 'Final',
type: 'final',
},
],
divisions: [
{
name: 'Frontmatter',
showNumberBeforeComponents: [],
allowedComponentTypes: ['component'],
defaultComponentType: 'component',
},
{
name: 'Body',
showNumberBeforeComponents: ['chapter'],
allowedComponentTypes: ['chapter', 'part', 'unnumbered'],
allowedComponentTypes: ['chapter'],
defaultComponentType: 'chapter',
},
{
name: 'Backmatter',
showNumberBeforeComponents: [],
allowedComponentTypes: ['component'],
defaultComponentType: 'component',
},
],
lockTrackChangesWhenReviewing: true,
}
......@@ -14,9 +14,7 @@ describe('BookBuilder', () => {
const productionEditorBook = books[0]
cy.visit(`/books/${productionEditorBook.id}/book-builder`)
cy.contains('FRONTMATTER')
cy.contains('BODY')
cy.contains('BACKMATTER')
})
})
})
# What did I do then ?
-----------------
### "titre descriptif de l'erreur"
#####why does it happens ?
#####what to do ?
#####occurence ?
-----------------
### app would not start after linking a new custom library
#####why does it happens ?
the folder in node_modules and the one linked are identical except for their own node_modules folder, the official one had its own folder containing dependencies
#####what to do ?
run yarn install inside the linked folder to install the required dependencies that aren't available in the main project
#####occurence ?
editoria/packages/api lib 2
-----------------
### when using yarn install in the main project an error occured while building/installing the bcrypt library
#####why does it happens ?
as of june 2019, the bcrypt library need a specific node version to work properly
#####what to do ?
use n or another package manager to change nodejs to 11.15.0 (not 11.13 nor 12)
#####occurence ?
2
-----------------
......@@ -35,4 +35,9 @@ yarn link pubsweet-component-editoria-navigation
cd ../custom_package/editoria/packages/bookbuilder
yarn link
cd -
yarn link pubsweet-component-bookbuilder
\ No newline at end of file
yarn link pubsweet-component-bookbuilder
cd ../custom_package/editoria/packages/api
yarn link
cd -
yarn link editoria-api
\ No newline at end of file
......@@ -13229,11 +13229,6 @@ pkginfo@0.3.x:
resolved "https://registry.yarnpkg.com/pkginfo/-/pkginfo-0.3.1.tgz#5b29f6a81f70717142e09e765bbeab97b4f81e21"
integrity sha1-Wyn2qB9wcXFC4J52W76rl7T4HiE=
pkginfo@0.x.x:
version "0.4.1"
resolved "https://registry.yarnpkg.com/pkginfo/-/pkginfo-0.4.1.tgz#b5418ef0439de5425fc4995042dced14fb2a84ff"
integrity sha1-tUGO8EOd5UJfxJlQQtztFPsqhP8=
platform@1.3.5:
version "1.3.5"
resolved "https://registry.yarnpkg.com/platform/-/platform-1.3.5.tgz#fb6958c696e07e2918d2eeda0f0bc9448d733444"
......@@ -13859,19 +13854,7 @@ promisify-event@^1.0.0:
dependencies:
pinkie-promise "^2.0.0"
prompt@^1.0.0:
version "1.0.0"
resolved "https://registry.yarnpkg.com/prompt/-/prompt-1.0.0.tgz#8e57123c396ab988897fb327fd3aedc3e735e4fe"
integrity sha1-jlcSPDlquYiJf7Mn/Trtw+c15P4=
dependencies:
colors "^1.1.2"
pkginfo "0.x.x"
read "1.0.x"
revalidator "0.1.x"
utile "0.3.x"
winston "2.1.x"
prompt@flatiron/prompt#1c95d1d8d333b5fbc13fa5f0619f3dcf0d514f87:
prompt@^1.0.0, prompt@flatiron/prompt#1c95d1d8d333b5fbc13fa5f0619f3dcf0d514f87:
version "1.0.0"
resolved "https://codeload.github.com/flatiron/prompt/tar.gz/1c95d1d8d333b5fbc13fa5f0619f3dcf0d514f87"
dependencies:
......@@ -18237,19 +18220,6 @@ winston@0.8.x:
pkginfo "0.3.x"
stack-trace "0.0.x"
winston@2.1.x:
version "2.1.1"
resolved "https://registry.yarnpkg.com/winston/-/winston-2.1.1.tgz#3c9349d196207fd1bdff9d4bc43ef72510e3a12e"
integrity sha1-PJNJ0ZYgf9G9/51LxD73JRDjoS4=
dependencies:
async "~1.0.0"
colors "1.0.x"
cycle "1.0.x"
eyes "0.1.x"
isstream "0.1.x"
pkginfo "0.3.x"
stack-trace "0.0.x"
winston@2.x, winston@^2.2.0:
version "2.4.4"
resolved "https://registry.yarnpkg.com/winston/-/winston-2.4.4.tgz#a01e4d1d0a103cf4eada6fc1f886b3110d71c34b"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment