Commit 61d2069f authored by Jure's avatar Jure
Browse files

Merge branch 'release' into 'master'

Publish

See merge request pubsweet/pubsweet!40
parents 36a5bebd e12ca962
{
"name": "pubsweet",
"version": "1.1.4",
"version": "1.1.5",
"description": "Pubsweet command-line interface, app generator and manager",
"bin": "./bin/pubsweet.js",
"scripts": {
......@@ -15,8 +15,8 @@
"author": "Collaborative Knowledge Foundation",
"license": "MIT",
"dependencies": {
"@pubsweet/db-manager": "^0.0.12",
"@pubsweet/logger": "^0.1.2",
"@pubsweet/db-manager": "^0.0.13",
"@pubsweet/logger": "^0.2.0",
"bluebird": "^3.5.0",
"colors": "^1.1.2",
"commander": "^2.9.0",
......@@ -25,7 +25,7 @@
"fs-extra": "^4.0.2",
"inflection": "^1.12.0",
"prompt": "flatiron/prompt#1c95d1d8d333b5fbc13fa5f0619f3dcf0d514f87",
"pubsweet-server": "^1.0.4",
"pubsweet-server": "^1.0.5",
"require-relative": "^0.8.7",
"uuid": "^3.0.1",
"webpack": "^3.8.1",
......
{
"name": "pubsweet-client",
"version": "1.1.2",
"version": "1.1.3",
"main": "src/index.js",
"scripts": {
"compile": "babel -d lib/ src/",
......
{
"name": "pubsweet-components",
"version": "0.0.5",
"version": "0.0.6",
"private": true,
"scripts": {
"styleguide": "styleguidist server",
"test": "jest --coverage"
},
"devDependencies": {
"@pubsweet/logger": "^0.1.2",
"@pubsweet/logger": "^0.2.0",
"babel-cli": "^6.26.0",
"babel-eslint": "^8.0.3",
"babel-loader": "^7.1.2",
......@@ -27,9 +27,9 @@
"joi-browser": "^13.0.1",
"lerna": "^2.5.1",
"node-sass": "^4.5.3",
"pubsweet": "^1.1.4",
"pubsweet-client": "^1.1.2",
"pubsweet-server": "^1.0.4",
"pubsweet": "^1.1.5",
"pubsweet-client": "^1.1.3",
"pubsweet-server": "^1.0.5",
"pubsweet-theme-plugin": "^0.0.3",
"react": "^15.6.1",
"react-dom": "^15.6.1",
......
{
"name": "pubsweet-component-epub",
"version": "0.2.6",
"version": "0.2.7",
"description": "Backend EPUB export component for PubSweet",
"main": "index.js",
"scripts": {
......@@ -9,7 +9,7 @@
"author": "Collaborative Knowledge Foundation",
"license": "MIT",
"dependencies": {
"@pubsweet/logger": "^0.1.2",
"@pubsweet/logger": "^0.2.0",
"cheerio": "^1.0.0-rc.2",
"html-epub": "^0.5.1",
"mkdirp": "^0.5.1",
......
{
"name": "pubsweet-component-form-group",
"version": "0.1.6",
"version": "0.1.7",
"description":
"Form component based on react-bootstrap with validation support for PubSweet",
"main": "index.js",
......@@ -9,7 +9,7 @@
"dependencies": {
"joi-browser": "^13.0.1",
"prop-types": "^15.5.10",
"pubsweet-server": "^1.0.4",
"pubsweet-server": "^1.0.5",
"react-bootstrap": "^0.31.3"
},
"peerDependencies": {
......
{
"name": "pubsweet-component-ink-backend",
"version": "0.2.2",
"version": "0.2.3",
"description": "Backend INK component for PubSweet",
"main": "index.js",
"author": "Collaborative Knowledge Foundation",
......@@ -9,7 +9,7 @@
"pubsweet-server": ">=0.8.1"
},
"dependencies": {
"@pubsweet/logger": "^0.1.2",
"@pubsweet/logger": "^0.2.0",
"busboy": "^0.2.13",
"config": "^1.26.1",
"pusher-js": "^4.2.1",
......
{
"name": "pubsweet-component-posts-manager",
"version": "0.6.6",
"version": "0.6.7",
"description": "Basic Posts manager component for PubSweet",
"main": "index.js",
"author": "Collaborative Knowledge Foundation",
"license": "MIT",
"dependencies": {
"prop-types": "^15.5.10",
"pubsweet-component-form-group": "^0.1.6",
"pubsweet-component-form-group": "^0.1.7",
"react-bootstrap": "^0.31.3",
"react-dom": "^15.6.1",
"react-redux": "^5.0.6",
......
{
"name": "@pubsweet/db-manager",
"version": "0.0.12",
"version": "0.0.13",
"description": "Provides database management utilities to Pubsweet apps.",
"main": "src/index.js",
"scripts": {
......@@ -33,11 +33,11 @@
"nsp": "^2.8.0"
},
"dependencies": {
"@pubsweet/logger": "^0.1.2",
"@pubsweet/logger": "^0.2.0",
"fs-extra": "^4.0.2",
"isomorphic-fetch": "^2.2.1",
"joi": "^13.1.0",
"pouchdb": "^6.3.4",
"pubsweet-server": "^1.0.4"
"pubsweet-server": "^1.0.5"
}
}
{
"name": "@pubsweet/logger",
"version": "0.1.2",
"version": "0.2.0",
"description":
"A module encapsulating standard logging features for pubsweet components and services.",
"main": "src/index.js",
......
{
"name": "pubsweet-server",
"version": "1.0.4",
"version": "1.0.5",
"scripts": {
"lint": "eslint src/ test/ config/",
"test": "jest",
......@@ -14,7 +14,7 @@
"license": "MIT",
"main": "src/index.js",
"dependencies": {
"@pubsweet/logger": "^0.1.2",
"@pubsweet/logger": "^0.2.0",
"authsome": "0.0.9",
"bcrypt": "^1.0.2",
"bluebird": "^3.5.1",
......
{
"name": "@pubsweet/styleguide",
"version": "0.1.2",
"version": "0.1.3",
"files": ["src", "dist"],
"main": "src",
"dependencies": {
"@pubsweet/theme": "^0.1.1",
"@pubsweet/theme": "^0.1.2",
"react": "^15.6.1",
"react-dom": "^15.6.1",
"react-redux": "^5.0.2",
......
{
"name": "@pubsweet/theme",
"version": "0.1.1",
"version": "0.1.2",
"description": "CSS for PubSweet apps and styleguides",
"main": "src",
"license": "MIT",
"dependencies": {
"cokourier-prime-sans": "git+https://gitlab.coko.foundation/julientaq/cokourier-sans-prime.git",
"cokourier-prime-sans":
"git+https://gitlab.coko.foundation/julientaq/cokourier-sans-prime.git",
"typeface-fira-mono": "^0.0.43",
"typeface-fira-sans": "^0.0.43",
"typeface-fira-sans-condensed": "^0.0.43",
......
{
"name": "@pubsweet/ui",
"version": "0.1.2",
"version": "0.2.0",
"files": ["docs", "dist", "src"],
"main": "src",
"jsnext:main": "src",
......@@ -27,7 +27,7 @@
"redux-form": "^7.0.3"
},
"devDependencies": {
"@pubsweet/styleguide": "^0.1.2",
"@pubsweet/styleguide": "^0.1.3",
"babel-core": "^6.26.0",
"babel-loader": "^7.1.2",
"babel-preset-env": "^1.6.0",
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment