Commit 81590970 authored by Alexandros Georgantas's avatar Alexandros Georgantas

Merge branch 'auto-save' into 'master'

Auto save

See merge request !2
parents 0b2a4c2e 81ac5758
......@@ -28,6 +28,7 @@ const Editor = WithConfig(Wax, {
layout: 'editoria',
lockWhenEditing: true,
pollingTimer: 1000,
autoSave: true,
})
// export default (
......
......@@ -49,7 +49,7 @@
"pubsweet-component-theme-editoria": "^0.0.4",
"pubsweet-component-users-manager": "1.0.0",
"pubsweet-component-vivliostyle-viewer": "^1.0.0",
"pubsweet-component-wax": "^0.6.10",
"pubsweet-component-wax": "^0.6.11",
"pubsweet-editoria-booksprints-authsome": "^1.0.0",
"pubsweet-server": "^7.2.0",
"pubsweet-theme-plugin": "^0.0.3",
......
......@@ -11056,9 +11056,9 @@ pubsweet-component-users-manager@1.0.0:
react-redux "^5.0.6"
redux "^3.7.2"
pubsweet-component-wax@^0.6.10:
version "0.6.10"
resolved "https://registry.yarnpkg.com/pubsweet-component-wax/-/pubsweet-component-wax-0.6.10.tgz#58328c670692f83ccd25890eb18f125486c066b9"
pubsweet-component-wax@^0.6.11:
version "0.6.11"
resolved "https://registry.yarnpkg.com/pubsweet-component-wax/-/pubsweet-component-wax-0.6.11.tgz#d91484695c00a0ef7fc5ffbe60e91ade74ddad32"
dependencies:
lodash "4.17.4"
pubsweet-client "^2.5.5"
......@@ -11066,7 +11066,7 @@ pubsweet-component-wax@^0.6.10:
react-dom "^16.2.0"
react-redux "5.0.4"
redux "3.6.0"
wax-editor-react "^0.2.6"
wax-editor-react "^0.2.7"
pubsweet-server@^7.1.0, pubsweet-server@^7.2.0:
version "7.2.0"
......@@ -14761,24 +14761,24 @@ watchpack@^1.3.1, watchpack@^1.4.0:
graceful-fs "^4.1.2"
neo-async "^2.5.0"
wax-editor-core@^0.6.5:
version "0.6.5"
resolved "https://registry.yarnpkg.com/wax-editor-core/-/wax-editor-core-0.6.5.tgz#fae9e39840d2a84da7f4f694317b642e7905a461"
wax-editor-core@^0.6.6:
version "0.6.6"
resolved "https://registry.yarnpkg.com/wax-editor-core/-/wax-editor-core-0.6.6.tgz#775c1d1a3e4efb851090675c984dca5390367058"
dependencies:
codemirror "^5.38.0"
font-awesome "^4.7.0"
lodash "^4.17.4"
substance "1.0.0-beta.6.5"
wax-editor-react@^0.2.6:
version "0.2.6"
resolved "https://registry.yarnpkg.com/wax-editor-react/-/wax-editor-react-0.2.6.tgz#c499427e447d24ad29e9fbd78e2b1f35558cf2b3"
wax-editor-react@^0.2.7:
version "0.2.7"
resolved "https://registry.yarnpkg.com/wax-editor-react/-/wax-editor-react-0.2.7.tgz#2aa32edc983078bf2d03b2f84f18ae865adde9ca"
dependencies:
lodash "^4.17.4"
react "^16.2.0"
react-dom "^16.2.0"
react-router-dom "^4.2.2"
wax-editor-core "^0.6.5"
wax-editor-core "^0.6.6"
wbuf@^1.1.0, wbuf@^1.7.2:
version "1.7.3"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment