Commit d114fa4a authored by Yannis Barlas's avatar Yannis Barlas
Browse files

remove eslint editoria and use eslint pubsweet

parent b7b45019
......@@ -4,6 +4,6 @@
"browser": true
},
"extends": [
"editoria"
"pubsweet"
]
}
......@@ -2,7 +2,7 @@
"author": "Yannis Barlas",
"description": "Monorepo grouping all the different parts of the Editoria project",
"devDependencies": {
"eslint-config-editoria": "^0.0.6",
"eslint-config-pubsweet": "^0.0.1",
"lerna": "^2.1.2"
},
"license": "MIT",
......
'use strict';
module.exports = {
"extends": [
"airbnb",
"standard",
"standard-react"
],
"rules": {
"react/jsx-filename-extension": [1, { "extensions": [".js", ".jsx"] }],
"sort-keys": [1, "asc", { "caseSensitive": false }]
},
"react/sort-comp": [1, {
"order": [
"constructor",
"lifecycle",
"everything-else",
"/^on.+$/",
"rendering"
],
"groups": {
"rendering": [
'/^render.+$/',
'render'
]
}
}]
};
{
"name": "eslint-config-editoria",
"version": "0.0.6",
"description": "A meta package to be used for the different parts of the editoria project",
"repository": "https://gitlab.coko.foundation/editoria/eslint-config-editoria",
"main": "index.js",
"scripts": {
"test": "echo \"Error: no test specified\" && exit 1"
},
"author": "",
"license": "ISC",
"dependencies": {
"eslint": "^3.19.0",
"eslint-config-airbnb": "^15.1.0",
"eslint-config-standard": "^10.2.1",
"eslint-config-standard-react": "^5.0.0",
"eslint-plugin-import": "^2.7.0",
"eslint-plugin-jsx-a11y": "^5.1.1",
"eslint-plugin-node": "^5.1.0",
"eslint-plugin-promise": "^3.5.0",
"eslint-plugin-react": "^7.1.0",
"eslint-plugin-standard": "^3.0.1"
},
"devDependencies": {}
}
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment