Commit 00172e70 authored by Jure's avatar Jure

Bump eslint dep

parent 8571fdcc
{
"env": {
"es6": true,
"browser": true
},
"extends": [
"pubsweet"
]
}
**/_build
**/node_modules
{
"extends": "stylelint-config-pubsweet"
}
......@@ -5,8 +5,8 @@
"devDependencies": {
"babel-eslint": "^8.0.1",
"babel-preset-es2015": "^6.24.1",
"eslint": "^4.11.0",
"eslint-config-pubsweet": "^0.0.5",
"eslint": "^4.13.1",
"eslint-config-pubsweet": "^0.0.6",
"eslint-plugin-import": "^2.8.0",
"eslint-plugin-jsx-a11y": "^6.0.2",
"eslint-plugin-node": "^5.2.1",
......@@ -19,7 +19,7 @@
"lint-staged": "^6.0.0",
"prettier": "^1.8.2",
"stylelint": "^8.2.0",
"stylelint-config-standard": "^17.0.0"
"stylelint-config-standard": "^18.0.0"
},
"scripts": {
"clean": "lerna clean",
......@@ -40,5 +40,9 @@
"workspaces": [
"packages/*",
"packages/components/packages/*"
]
],
"dependencies": {
"eslint-config-stylelint": "^8.0.0",
"stylelint-config-pubsweet": "^0.0.3"
}
}
......@@ -38,7 +38,7 @@
"author": "Samuel Galson",
"license": "MIT",
"devDependencies": {
"eslint": "^4.8.0",
"eslint": "^4.13.1",
"eslint-config-prettier": "^2.6.0",
"eslint-config-standard": "^11.0.0-beta.0",
"eslint-plugin-import": "^2.7.0",
......
......@@ -3404,15 +3404,6 @@ eslint-config-prettier@^2.6.0, eslint-config-prettier@^2.7.0:
dependencies:
get-stdin "^5.0.1"
eslint-config-pubsweet@^0.0.5:
version "0.0.5"
resolved "https://registry.yarnpkg.com/eslint-config-pubsweet/-/eslint-config-pubsweet-0.0.5.tgz#7e6b3ee115c9281fd85a55c255a975b02b5d0bdb"
dependencies:
eslint-config-airbnb "^16.1.0"
eslint-config-prettier "^2.7.0"
eslint-config-standard "^10.2.1"
eslint-config-standard-react "^5.0.0"
eslint-config-pubsweet@^0.0.6:
version "0.0.6"
resolved "https://registry.yarnpkg.com/eslint-config-pubsweet/-/eslint-config-pubsweet-0.0.6.tgz#cb29cd241a33efab96f9ba8947d56f4b4b4cd5aa"
......@@ -3440,6 +3431,13 @@ eslint-config-standard@^11.0.0-beta.0:
version "11.0.0-beta.0"
resolved "https://registry.yarnpkg.com/eslint-config-standard/-/eslint-config-standard-11.0.0-beta.0.tgz#f8afe69803d95c685a4b8392b8793188eb03cbb3"
eslint-config-stylelint@^8.0.0:
version "8.0.0"
resolved "https://registry.yarnpkg.com/eslint-config-stylelint/-/eslint-config-stylelint-8.0.0.tgz#1ee70ddd33f2802db6b074feb30990713b5b50f3"
dependencies:
eslint-plugin-node "^5.2.1"
eslint-plugin-sort-requires "^2.1.0"
eslint-import-resolver-node@^0.2.0:
version "0.2.3"
resolved "https://registry.yarnpkg.com/eslint-import-resolver-node/-/eslint-import-resolver-node-0.2.3.tgz#5add8106e8c928db2cba232bcd9efa846e3da16c"
......@@ -3557,6 +3555,10 @@ eslint-plugin-react@~6.10.0:
jsx-ast-utils "^1.3.4"
object.assign "^4.0.4"
eslint-plugin-sort-requires@^2.1.0:
version "2.1.0"
resolved "https://registry.yarnpkg.com/eslint-plugin-sort-requires/-/eslint-plugin-sort-requires-2.1.0.tgz#3efad948dc83798219e809f54067c40e55444861"
eslint-plugin-standard@^3.0.1, eslint-plugin-standard@~3.0.1:
version "3.0.1"
resolved "https://registry.yarnpkg.com/eslint-plugin-standard/-/eslint-plugin-standard-3.0.1.tgz#34d0c915b45edc6f010393c7eef3823b08565cf2"
......@@ -3572,7 +3574,7 @@ eslint-scope@^3.7.1:
esrecurse "^4.1.0"
estraverse "^4.1.1"
eslint@^4.0.0, eslint@^4.11.0, eslint@^4.13.0, eslint@^4.5.0, eslint@^4.8.0:
eslint@^4.0.0, eslint@^4.13.0, eslint@^4.5.0, eslint@^4.8.0:
version "4.13.0"
resolved "https://registry.yarnpkg.com/eslint/-/eslint-4.13.0.tgz#1991aa359586af83877bde59de9d41f53e20826d"
dependencies:
......@@ -3614,6 +3616,48 @@ eslint@^4.0.0, eslint@^4.11.0, eslint@^4.13.0, eslint@^4.5.0, eslint@^4.8.0:
table "^4.0.1"
text-table "~0.2.0"
eslint@^4.13.1:
version "4.13.1"
resolved "https://registry.yarnpkg.com/eslint/-/eslint-4.13.1.tgz#0055e0014464c7eb7878caf549ef2941992b444f"
dependencies:
ajv "^5.3.0"
babel-code-frame "^6.22.0"
chalk "^2.1.0"
concat-stream "^1.6.0"
cross-spawn "^5.1.0"
debug "^3.0.1"
doctrine "^2.0.2"
eslint-scope "^3.7.1"
espree "^3.5.2"
esquery "^1.0.0"
estraverse "^4.2.0"
esutils "^2.0.2"
file-entry-cache "^2.0.0"
functional-red-black-tree "^1.0.1"
glob "^7.1.2"
globals "^11.0.1"
ignore "^3.3.3"
imurmurhash "^0.1.4"
inquirer "^3.0.6"
is-resolvable "^1.0.0"
js-yaml "^3.9.1"
json-stable-stringify-without-jsonify "^1.0.1"
levn "^0.3.0"
lodash "^4.17.4"
minimatch "^3.0.2"
mkdirp "^0.5.1"
natural-compare "^1.4.0"
optionator "^0.8.2"
path-is-inside "^1.0.2"
pluralize "^7.0.0"
progress "^2.0.0"
require-uncached "^1.0.3"
semver "^5.3.0"
strip-ansi "^4.0.0"
strip-json-comments "~2.0.1"
table "^4.0.1"
text-table "~0.2.0"
eslint@~3.19.0:
version "3.19.0"
resolved "https://registry.yarnpkg.com/eslint/-/eslint-3.19.0.tgz#c8fc6201c7f40dd08941b87c085767386a679acc"
......@@ -8194,6 +8238,13 @@ postcss-selector-parser@^3.1.0:
indexes-of "^1.0.1"
uniq "^1.0.1"
postcss-sorting@^3.0.2:
version "3.1.0"
resolved "https://registry.yarnpkg.com/postcss-sorting/-/postcss-sorting-3.1.0.tgz#af7c90ee73ad12569a57664eaf06735c2e25bec0"
dependencies:
lodash "^4.17.4"
postcss "^6.0.13"
postcss-svgo@^2.1.1:
version "2.1.6"
resolved "https://registry.yarnpkg.com/postcss-svgo/-/postcss-svgo-2.1.6.tgz#b6df18aa613b666e133f08adb5219c2684ac108d"
......@@ -8232,7 +8283,7 @@ postcss@^5.0.10, postcss@^5.0.11, postcss@^5.0.12, postcss@^5.0.13, postcss@^5.0
source-map "^0.5.6"
supports-color "^3.2.3"
postcss@^6.0.1, postcss@^6.0.14, postcss@^6.0.3, postcss@^6.0.6, postcss@^6.0.8:
postcss@^6.0.1, postcss@^6.0.11, postcss@^6.0.13, postcss@^6.0.14, postcss@^6.0.3, postcss@^6.0.6, postcss@^6.0.8:
version "6.0.14"
resolved "https://registry.yarnpkg.com/postcss/-/postcss-6.0.14.tgz#5534c72114739e75d0afcf017db853099f562885"
dependencies:
......@@ -10508,26 +10559,32 @@ style-search@^0.1.0:
version "0.1.0"
resolved "https://registry.yarnpkg.com/style-search/-/style-search-0.1.0.tgz#7958c793e47e32e07d2b5cafe5c0bf8e12e77902"
stylelint-config-recommended@^1.0.0:
version "1.0.0"
resolved "https://registry.yarnpkg.com/stylelint-config-recommended/-/stylelint-config-recommended-1.0.0.tgz#752c17fc68fa64cd5e7589e24f6e46e77e14a735"
stylelint-config-pubsweet@^0.0.3:
version "0.0.3"
resolved "https://registry.yarnpkg.com/stylelint-config-pubsweet/-/stylelint-config-pubsweet-0.0.3.tgz#1f2284a5ffca26dcfa6bfee225b6f65bbcb2d2f5"
dependencies:
stylelint "^8.2.0"
stylelint-config-standard "^18.0.0"
stylelint-order "^0.7.0"
stylelint-config-recommended@^2.0.0:
version "2.0.0"
resolved "https://registry.yarnpkg.com/stylelint-config-recommended/-/stylelint-config-recommended-2.0.0.tgz#560a028e81ea3ca8894b9a8eef4c0e05ac60e090"
stylelint-config-standard@^17.0.0:
version "17.0.0"
resolved "https://registry.yarnpkg.com/stylelint-config-standard/-/stylelint-config-standard-17.0.0.tgz#42103a090054ee2a3dde9ecaed55e5d4d9d059fc"
dependencies:
stylelint-config-recommended "^1.0.0"
stylelint-config-standard@^18.0.0:
version "18.0.0"
resolved "https://registry.yarnpkg.com/stylelint-config-standard/-/stylelint-config-standard-18.0.0.tgz#0d872b40fafdcddcf4188fb5b64ddb3887e8aefc"
dependencies:
stylelint-config-recommended "^2.0.0"
stylelint-order@^0.7.0:
version "0.7.0"
resolved "https://registry.yarnpkg.com/stylelint-order/-/stylelint-order-0.7.0.tgz#ceab5cbe24aa33fa63590024995395f6edfc9ab7"
dependencies:
lodash "^4.17.4"
postcss "^6.0.11"
postcss-sorting "^3.0.2"
stylelint@^8.2.0:
version "8.3.1"
resolved "https://registry.yarnpkg.com/stylelint/-/stylelint-8.3.1.tgz#424c822f32c88e85025b55d72c7b98355e3fa6de"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment