Commit 313df580 authored by Sam Galson's avatar Sam Galson

revert server dep

parent 4d61afe9
......@@ -23,7 +23,7 @@
"pubsweet-component-signup": "^0.2.0",
"pubsweet-component-teams-manager": "^0.1.7",
"pubsweet-component-users-manager": "^0.1.6",
"pubsweet-server": "git+https://gitlab.coko.foundation/yld/pubsweet-server.git#feat/recreate-db",
"pubsweet-server": "^1.0.0-alpha.3",
"pubsweet-theme-plugin": "^0.0.1"
},
"devDependencies": {
......
......@@ -6419,10 +6419,6 @@ pkginfo@0.3.x:
version "0.3.1"
resolved "https://registry.yarnpkg.com/pkginfo/-/pkginfo-0.3.1.tgz#5b29f6a81f70717142e09e765bbeab97b4f81e21"
pkginfo@0.x.x:
version "0.4.1"
resolved "https://registry.yarnpkg.com/pkginfo/-/pkginfo-0.4.1.tgz#b5418ef0439de5425fc4995042dced14fb2a84ff"
platform@1.3.4:
version "1.3.4"
resolved "https://registry.yarnpkg.com/platform/-/platform-1.3.4.tgz#6f0fb17edaaa48f21442b3a975c063130f1c3ebd"
......@@ -7253,18 +7249,7 @@ promise@^7.1.1:
dependencies:
asap "~2.0.3"
prompt@^1.0.0:
version "1.0.0"
resolved "https://registry.yarnpkg.com/prompt/-/prompt-1.0.0.tgz#8e57123c396ab988897fb327fd3aedc3e735e4fe"
dependencies:
colors "^1.1.2"
pkginfo "0.x.x"
read "1.0.x"
revalidator "0.1.x"
utile "0.3.x"
winston "2.1.x"
prompt@flatiron/prompt#1c95d1d8d333b5fbc13fa5f0619f3dcf0d514f87:
prompt@^1.0.0, prompt@flatiron/prompt#1c95d1d8d333b5fbc13fa5f0619f3dcf0d514f87:
version "1.0.0"
resolved "https://codeload.github.com/flatiron/prompt/tar.gz/1c95d1d8d333b5fbc13fa5f0619f3dcf0d514f87"
dependencies:
......@@ -7458,6 +7443,41 @@ pubsweet-server@1.0.0-alpha.2:
uuid "^3.0.1"
winston "^2.2.0"
pubsweet-server@^1.0.0-alpha.3:
version "1.0.0-alpha.3"
resolved "https://registry.yarnpkg.com/pubsweet-server/-/pubsweet-server-1.0.0-alpha.3.tgz#82e48eabc182005078e614c76ce859f524b887a3"
dependencies:
authsome "0.0.4"
bcrypt "^1.0.2"
body-parser "^1.15.2"
colors "^1.1.2"
config "^1.26.2"
cookie-parser "^1.4.3"
express "^4.14.0"
helmet "^3.8.1"
http-status-codes "^1.0.6"
joi "^10.0.6"
jsonwebtoken "^7.1.7"
lodash "^4.0.0"
minimist "^1.2.0"
morgan "^1.7.0"
multer "^1.1.0"
passport "^0.3.2"
passport-anonymous "^1.0.1"
passport-http-bearer "^1.0.1"
passport-local "^1.0.0"
pouchdb-adapter-http "^6.2.0"
pouchdb-adapter-leveldb "^6.1.1"
pouchdb-core "^6.1.1"
pouchdb-find "^0.10.3"
pouchdb-upsert "^2.0.0"
promise-queue "^2.2.3"
prompt "^1.0.0"
pubsweet-sse "^0.1.1"
relational-pouch "^1.4.5"
uuid "^3.0.1"
winston "^2.2.0"
"pubsweet-server@git+https://gitlab.coko.foundation/yld/pubsweet-server.git#feat/recreate-db":
version "1.0.0-alpha.3"
resolved "git+https://gitlab.coko.foundation/yld/pubsweet-server.git#358875452dce2a88dee911ca5c84456d7e31f8ed"
......@@ -9433,18 +9453,6 @@ winston@0.8.x:
pkginfo "0.3.x"
stack-trace "0.0.x"
winston@2.1.x:
version "2.1.1"
resolved "https://registry.yarnpkg.com/winston/-/winston-2.1.1.tgz#3c9349d196207fd1bdff9d4bc43ef72510e3a12e"
dependencies:
async "~1.0.0"
colors "1.0.x"
cycle "1.0.x"
eyes "0.1.x"
isstream "0.1.x"
pkginfo "0.3.x"
stack-trace "0.0.x"
winston@2.x, winston@^2.2.0:
version "2.3.1"
resolved "https://registry.yarnpkg.com/winston/-/winston-2.3.1.tgz#0b48420d978c01804cf0230b648861598225a119"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment