Commit 605ff208 authored by Tamlyn Rhodes's avatar Tamlyn Rhodes

Merge remote-tracking branch 'origin/master' into config

parents ad0c4350 aa05f98b
# Created by https://www.gitignore.io/api/osx,node
### OSX ###
*.DS_Store
.AppleDouble
.LSOverride
# Icon must end with two \r
Icon
# Thumbnails
._*
# Files that might appear in the root of a volume
.DocumentRevisions-V100
.fseventsd
.Spotlight-V100
.TemporaryItems
.Trashes
.VolumeIcon.icns
.com.apple.timemachine.donotpresent
# Directories potentially created on remote AFP share
.AppleDB
.AppleDesktop
Network Trash Folder
Temporary Items
.apdisk
### Node ###
# Logs
*.log
npm-debug.log*
# Runtime data
pids
*.pid
*.seed
*.pid.lock
# Directory for instrumented libs generated by jscoverage/JSCover
lib-cov
# Coverage directory used by tools like istanbul
coverage
# nyc test coverage
.nyc_output
# Grunt intermediate storage (http://gruntjs.com/creating-plugins#storing-task-files)
.grunt
# node-waf configuration
.lock-wscript
# Compiled binary addons (http://nodejs.org/api/addons.html)
build/Release
# Dependency directories
node_modules
jspm_packages
# Optional npm cache directory
.npm
# Optional eslint cache
.eslintcache
# Optional REPL history
.node_repl_history
# Output of 'npm pack'
*.tgz
# IDEs
.idea
# pubsweet-specific
myapp
testapp
api
.vscode
.wallaby.js
logs
node_modules
.env.*
_build
coverage/
yarn-error.log
package-lock.json
{
"name": "pubsweet-starter",
"name": "@pubsweet/starter",
"version": "1.0.0-alpha.1",
"description": "A new pubsweet app",
"files": [
......@@ -58,7 +58,7 @@
"html-webpack-plugin": "^2.24.0",
"joi-browser": "^10.0.6",
"json-loader": "^0.5.4",
"nightmare": "git+https://git@github.com/segmentio/nightmare.git#master",
"nightmare": "segmentio/nightmare",
"nightmare-wait-for-url": "^0.0.2",
"node-sass": "^4.5.2",
"pouchdb-adapter-memory": "^6.1.1",
......
......@@ -10,7 +10,7 @@ module.exports = [
{
// The configuration for the client
name: 'app',
target: 'web',
target: 'electron-main',
context: path.join(__dirname, '..', 'app'),
entry: {
app: [
......
......@@ -7,12 +7,11 @@
resolved "https://registry.yarnpkg.com/@jkroso/type/-/type-1.1.1.tgz#22903a346f633f2c65c0f6a938caafc43f181f17"
"@pubsweet/db-manager@git+https://gitlab.coko.foundation/yld/db-manager.git":
version "0.0.2"
resolved "git+https://gitlab.coko.foundation/yld/db-manager.git#c4ca7c2741cb6446a2f94582549db33edc5071c3"
version "0.0.1"
resolved "git+https://gitlab.coko.foundation/yld/db-manager.git#919c6629f3822063dea88b7d4b1372d279167e47"
dependencies:
"@pubsweet/logger" "0.0.1"
fs-extra "^4.0.2"
isomorphic-fetch "^2.2.1"
joi "^11.0.2"
pouchdb "^6.3.4"
pubsweet-server "git+https://gitlab.coko.foundation/yld/pubsweet-server.git#feat/recreate-db"
......@@ -26,7 +25,7 @@
"@pubsweet/starter@git+https://gitlab.coko.foundation/yld/pubsweet-starter.git#cli-refactor":
version "1.0.0-alpha.1"
resolved "git+https://gitlab.coko.foundation/yld/pubsweet-starter.git#63ec3d5f81ea8c6cc3df342f45ec05a6eed688a0"
resolved "git+https://gitlab.coko.foundation/yld/pubsweet-starter.git#c5f652ace61450627e2725b019b3334defc4415e"
dependencies:
"@pubsweet/logger" "^0.0.1"
jest "^21.1.0"
......@@ -42,7 +41,7 @@
pubsweet-component-signup "^0.2.0"
pubsweet-component-teams-manager "^0.1.7"
pubsweet-component-users-manager "^0.1.6"
pubsweet-server "git+https://gitlab.coko.foundation/yld/pubsweet-server.git#feat/recreate-db"
pubsweet-server "1.0.0-alpha.2"
pubsweet-theme-plugin "^0.0.1"
"@types/node@^7.0.18":
......@@ -2042,14 +2041,14 @@ config@^1.21.0, config@^1.26.2:
json5 "0.4.0"
os-homedir "1.0.2"
connect@3.6.5:
version "3.6.5"
resolved "https://registry.yarnpkg.com/connect/-/connect-3.6.5.tgz#fb8dde7ba0763877d0ec9df9dac0b4b40e72c7da"
connect@3.6.2:
version "3.6.2"
resolved "https://registry.yarnpkg.com/connect/-/connect-3.6.2.tgz#694e8d20681bfe490282c8ab886be98f09f42fe7"
dependencies:
debug "2.6.9"
finalhandler "1.0.6"
parseurl "~1.3.2"
utils-merge "1.0.1"
debug "2.6.7"
finalhandler "1.0.3"
parseurl "~1.3.1"
utils-merge "1.0.0"
console-browserify@^1.1.0:
version "1.1.0"
......@@ -2418,12 +2417,24 @@ debug@2.6.4:
dependencies:
ms "0.7.3"
debug@2.6.9, debug@^2.1.0, debug@^2.1.1, debug@^2.1.3, debug@^2.2.0, debug@^2.6.3, debug@^2.6.8:
debug@2.6.7:
version "2.6.7"
resolved "https://registry.yarnpkg.com/debug/-/debug-2.6.7.tgz#92bad1f6d05bbb6bba22cca88bcd0ec894c2861e"
dependencies:
ms "2.0.0"
debug@2.6.9:
version "2.6.9"
resolved "https://registry.yarnpkg.com/debug/-/debug-2.6.9.tgz#5d128515df134ff327e90a4c93f4e077a536341f"
dependencies:
ms "2.0.0"
debug@^2.1.0, debug@^2.1.1, debug@^2.1.3, debug@^2.2.0, debug@^2.6.3, debug@^2.6.8:
version "2.6.8"
resolved "https://registry.yarnpkg.com/debug/-/debug-2.6.8.tgz#e731531ca2ede27d188222427da17821d68ff4fc"
dependencies:
ms "2.0.0"
debug@^3.0.1:
version "3.1.0"
resolved "https://registry.yarnpkg.com/debug/-/debug-3.1.0.tgz#5bb5a0672628b64149566ba16819e61518c67261"
......@@ -3512,15 +3523,15 @@ fill-range@^2.1.0:
repeat-element "^1.1.2"
repeat-string "^1.5.2"
finalhandler@1.0.6:
version "1.0.6"
resolved "https://registry.yarnpkg.com/finalhandler/-/finalhandler-1.0.6.tgz#007aea33d1a4d3e42017f624848ad58d212f814f"
finalhandler@1.0.3:
version "1.0.3"
resolved "https://registry.yarnpkg.com/finalhandler/-/finalhandler-1.0.3.tgz#ef47e77950e999780e86022a560e3217e0d0cc89"
dependencies:
debug "2.6.9"
debug "2.6.7"
encodeurl "~1.0.1"
escape-html "~1.0.3"
on-finished "~2.3.0"
parseurl "~1.3.2"
parseurl "~1.3.1"
statuses "~1.3.1"
unpipe "~1.0.0"
......@@ -4048,10 +4059,10 @@ helmet-csp@2.5.1:
platform "1.3.4"
helmet@^3.8.1:
version "3.8.2"
resolved "https://registry.yarnpkg.com/helmet/-/helmet-3.8.2.tgz#64f988b8e9d8773ad201da455b8b6a754c229aaa"
version "3.8.1"
resolved "https://registry.yarnpkg.com/helmet/-/helmet-3.8.1.tgz#bef2b68ffbaa19759e858c19cca7db213bb58b2d"
dependencies:
connect "3.6.5"
connect "3.6.2"
dns-prefetch-control "0.1.0"
dont-sniff-mimetype "1.0.0"
expect-ct "0.1.0"
......@@ -4703,7 +4714,7 @@ isobject@^3.0.1:
version "3.0.1"
resolved "https://registry.yarnpkg.com/isobject/-/isobject-3.0.1.tgz#4e431e92b11a9731636aa1f9c8d1ccbcfdab78df"
isomorphic-fetch@^2.1.1, isomorphic-fetch@^2.2.1:
isomorphic-fetch@^2.1.1:
version "2.2.1"
resolved "https://registry.yarnpkg.com/isomorphic-fetch/-/isomorphic-fetch-2.2.1.tgz#611ae1acf14f5e81f729507472819fe9733558a9"
dependencies:
......@@ -5899,9 +5910,9 @@ nightmare-wait-for-url@^0.0.2:
debug "^2.2.0"
nightmare "^2.3.0"
nightmare@^2.3.0, "nightmare@git+https://git@github.com/segmentio/nightmare.git#master":
nightmare@^2.3.0, nightmare@segmentio/nightmare:
version "2.10.0"
resolved "git+https://git@github.com/segmentio/nightmare.git#7d1b8a40b6f5857a06e7f20440fc4f416c54e9a1"
resolved "https://codeload.github.com/segmentio/nightmare/tar.gz/7d1b8a40b6f5857a06e7f20440fc4f416c54e9a1"
dependencies:
debug "^2.2.0"
deep-defaults "^1.0.3"
......@@ -6431,7 +6442,7 @@ parse5@^1.5.1:
version "1.5.1"
resolved "https://registry.yarnpkg.com/parse5/-/parse5-1.5.1.tgz#9b7f3b0de32be78dc2401b17573ccaf0f6f59d94"
parseurl@~1.3.2:
parseurl@~1.3.1, parseurl@~1.3.2:
version "1.3.2"
resolved "https://registry.yarnpkg.com/parseurl/-/parseurl-1.3.2.tgz#fc289d4ed8993119460c156253262cdc8de65bf3"
......@@ -7771,7 +7782,7 @@ pubsweet-server@1.0.0-alpha.2:
uuid "^3.0.1"
winston "^2.2.0"
pubsweet-server@^1.0.0-alpha.3, "pubsweet-server@git+https://gitlab.coko.foundation/yld/pubsweet-server.git#feat/recreate-db":
pubsweet-server@^1.0.0-alpha.2, pubsweet-server@^1.0.0-alpha.3, "pubsweet-server@git+https://gitlab.coko.foundation/yld/pubsweet-server.git#feat/recreate-db":
version "1.0.0-alpha.3"
resolved "git+https://gitlab.coko.foundation/yld/pubsweet-server.git#358875452dce2a88dee911ca5c84456d7e31f8ed"
dependencies:
......@@ -7846,32 +7857,28 @@ pubsweet-theme-plugin@^0.0.1:
"pubsweet@git+https://gitlab.coko.foundation/yld/pubsweet-cli.git#refactor/db-manager":
version "1.0.0-alpha.4"
uid "5a5c13cb77e98c04b025f72cceee4efbe29ece87"
resolved "git+https://gitlab.coko.foundation/yld/pubsweet-cli.git#5a5c13cb77e98c04b025f72cceee4efbe29ece87"
resolved "git+https://gitlab.coko.foundation/yld/pubsweet-cli.git#87feeb3aa930d3ea39ab4e41f6e415749a6888c5"
dependencies:
"@pubsweet/db-manager" "git+https://gitlab.coko.foundation/yld/db-manager.git"
"@pubsweet/logger" "^0.0.1"
"@pubsweet/starter" "git+https://gitlab.coko.foundation/yld/pubsweet-starter.git#cli-refactor"
app-module-path "^2.2.0"
authsome "0.0.4"
bluebird "^3.5.0"
child-process-promise "^2.2.1"
chokidar "^1.6.1"
colors "^1.1.2"
commander "^2.9.0"
dotenv "^4.0.0"
express "^4.15.3"
express-pouchdb "^2.3.7"
forever-monitor "^1.7.0"
fs-extra "^3.0.0"
html-webpack-plugin "^2.24.0"
inflection "^1.12.0"
joi "^10.4.1"
pouchdb "^6.2.0"
prompt flatiron/prompt#1c95d1d8d333b5fbc13fa5f0619f3dcf0d514f87
pubsweet-server "git+https://gitlab.coko.foundation/yld/pubsweet-server.git#feat/recreate-db"
pubsweet-server "^1.0.0-alpha.2"
uuid "^3.0.1"
webpack "^2.3.2"
webpack-dev-middleware "^1.12.0"
webpack-hot-middleware "^2.19.1"
yarn "^1.0.0"
pump@^1.0.0:
......@@ -8710,11 +8717,7 @@ secure-random@^1.1.1:
version "1.1.1"
resolved "https://registry.yarnpkg.com/secure-random/-/secure-random-1.1.1.tgz#0880f2d8c5185f4bcb4684058c836b4ddb07145a"
"semver@2 || 3 || 4 || 5", "semver@2.x || 3.x || 4 || 5", semver@^5.3.0:
version "5.4.1"
resolved "https://registry.yarnpkg.com/semver/-/semver-5.4.1.tgz#e059c09d8571f0540823733433505d3a2f00b18e"
semver@5.3.0, semver@~5.3.0:
"semver@2 || 3 || 4 || 5", "semver@2.x || 3.x || 4 || 5", semver@5.3.0, semver@^5.3.0, semver@~5.3.0:
version "5.3.0"
resolved "https://registry.yarnpkg.com/semver/-/semver-5.3.0.tgz#9b2ce5d3de02d17c6012ad326aa6b4d0cf54f94f"
......@@ -9632,6 +9635,10 @@ utile@0.3.x:
ncp "1.0.x"
rimraf "2.x.x"
utils-merge@1.0.0:
version "1.0.0"
resolved "https://registry.yarnpkg.com/utils-merge/-/utils-merge-1.0.0.tgz#0294fb922bb9375153541c4f7096231f287c8af8"
utils-merge@1.0.1:
version "1.0.1"
resolved "https://registry.yarnpkg.com/utils-merge/-/utils-merge-1.0.1.tgz#9f95710f50a267947b2ccc124741c1028427e713"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment