Commit bf743233 authored by Yannis Barlas's avatar Yannis Barlas
Browse files

chore(*): upgrade styled & react major versions

parent 1308cbc2
......@@ -17,7 +17,7 @@
"prop-types": "^15.5.10",
"react-router-dom": "^5.0.0",
"recompose": "^0.30.0",
"styled-components": "^4.1.3"
"styled-components": "^5.2.3"
},
"peerDependencies": {
"@apollo/client": "^3.2.7",
......@@ -25,7 +25,7 @@
"config": ">=3.0.1",
"lodash": ">=4.17.11",
"react": ">=16.9",
"styled-components": ">=4.1.3"
"styled-components": "^5.2.3"
},
"gitHead": "6b100b76f21785e5e50fca082a2743d3d0b1c88a"
}
......@@ -16,7 +16,7 @@
"@pubsweet/client": ">=11.0.0",
"react": ">=16.9",
"react-router-dom": "^5.0.0",
"styled-components": "^4.1.1"
"styled-components": "^5.2.3"
},
"publishConfig": {
"access": "public"
......
......@@ -14,7 +14,7 @@
"peerDependencies": {
"@pubsweet/client": ">=11.0.0",
"react": ">=16.9",
"styled-components": ">=4.1.3"
"styled-components": ">=5.2.3"
},
"repository": {
"type": "git",
......
......@@ -20,7 +20,7 @@
"@apollo/client": "^3.2.7",
"@pubsweet/client": ">=11.0.0",
"react": ">=16.9",
"styled-components": ">=4.1.3"
"styled-components": "^5.2.3"
},
"publishConfig": {
"access": "public"
......
......@@ -11,7 +11,7 @@
"peerDependencies": {
"lodash": "^4.17.11",
"react": ">=16.9",
"react-dom": "^16.9.0"
"react-dom": ">=16.9"
},
"devDependencies": {
"react-dnd-test-backend": "^7.0.0"
......
......@@ -28,7 +28,7 @@
"lodash": ">=4.17.11",
"prop-types": ">=15.6.2",
"react": ">=16.9",
"styled-components": ">=4.1.3"
"styled-components": "^5.2.3"
},
"gitHead": "6b100b76f21785e5e50fca082a2743d3d0b1c88a"
}
......@@ -21,22 +21,22 @@
"@hapi/joi": "^14.3.1",
"@pubsweet/client": "^11.0.0",
"@pubsweet/default-theme": "^4.0.12",
"@pubsweet/ui": "^10.0.4",
"@pubsweet/ui-toolkit": "^2.1.4",
"@pubsweet/ui": "^12.6.10",
"@pubsweet/ui-toolkit": "^2.3.12",
"config": "^3.0.1",
"faker": "^4.1.0",
"fs-extra": "^8.1.0",
"joi-browser": "^13.4.0",
"lodash": "^4.17.5",
"react": "^16.9.0",
"react": "^17.0.2",
"react-dnd": "^10.0.2",
"react-dnd-html5-backend": "^10.0.2",
"react-dom": "^16.9.0",
"react-dom": "^17.0.2",
"react-router-dom": "^5.0.0",
"react-styleguidist": "^11.0.5",
"recompose": "^0.26.0",
"regenerator-runtime": "^0.13.1",
"styled-components": "^4.1.1",
"styled-components": "^5.2.3",
"styled-normalize": "^8.0.6",
"webpack": "^4.29.5",
"xpub-journal": "^0.0.3"
......
......@@ -23,9 +23,9 @@
"graphql": "^14.2.1",
"isomorphic-fetch": "^2.1.1",
"prop-types": "^15.5.8",
"react": "^16.9.0",
"react": "^17.0.2",
"react-router-dom": "^5.0.0",
"styled-components": "^4.1.1",
"styled-components": "^5.2.3",
"styled-normalize": "^8.0.6"
},
"devDependencies": {
......@@ -33,7 +33,7 @@
"enzyme-adapter-react-16": "^1.15.5",
"history": "^5.0.0",
"html-webpack-plugin": "^4.5.0",
"react-dom": "^17.0.1",
"react-dom": "^17.0.2",
"uuid": "^8.3.1",
"waait": "^1.0.5",
"webpack": "^5.5.0",
......
......@@ -17,7 +17,7 @@
"dependencies": {
"color": "^3.0.0",
"lodash": "^4.17.4",
"styled-components": "^4.1.1"
"styled-components": "^5.2.3"
},
"author": "Adam Hyde",
"license": "MIT",
......
......@@ -16,15 +16,15 @@
"lodash": "^4.17.4",
"moment": "^2.22.1",
"prop-types": "^15.5.10",
"react": "^16.9.0",
"react-dom": "^16.9.0",
"react": "^17.0.2",
"react-dom": "^17.0.2",
"react-feather": "^1.0.8",
"react-router-dom": "^5.0.0",
"react-select": "^3.0.8",
"react-tag-autocomplete": "^5.5.0",
"react-uid": "^2.2.0",
"recompose": "^0.30.0",
"styled-components": "^4.1.1"
"styled-components": "^5.2.3"
},
"scripts": {
"build": "babel --delete-dir-on-start --root-mode upward src -d dist --ignore node_modules,test,docs",
......
This diff is collapsed.
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment