Commit 1b3f47fa authored by Yuci Gou's avatar Yuci Gou
Browse files

Upgrade Minio middleware

parent d3727016
Pipeline #13396 failed with stages
in 28 seconds
This diff is collapsed.
......@@ -13,7 +13,9 @@
"url": "https://gitlab.coko.foundation/xpub/xpub-epmc.git"
},
"dependencies": {
"@babel/core": "^7.3.4",
"@babel/polyfill": "^7.4.4",
"@europepmc/express-middleware-minio": "^3.2.5",
"@pubsweet/base-model": "^1.0.9",
"@pubsweet/component-send-email": "^0.2.4",
"@pubsweet/db-manager": "^2.2.3",
......@@ -25,10 +27,20 @@
"apollo-boost": "^0.1.22",
"apollo-client": "^2.3.7",
"babel-core": "^6.26.0",
"babel-eslint": "^8.0.2",
"babel-jest": "^24.5.0",
"babel-loader": "^7.1.2",
"babel-preset-env": "^1.6.0",
"babel-preset-es2015": "^6.24.1",
"babel-preset-react": "^6.24.1",
"babel-preset-stage-2": "^6.24.1",
"benmark": "^1.1.2",
"chokidar": "^2.0.4",
"clean-webpack-plugin": "^0.1.17",
"config": "^1.26.2",
"configstore": "^4.0.0",
"copy-webpack-plugin": "^4.0.1",
"css-loader": "^0.28.4",
"curl-request": "^1.1.1",
"dateformat": "^3.0.3",
"decode-html": "^2.0.0",
......@@ -36,8 +48,19 @@
"download": "^7.1.0",
"email-validator": "^2.0.4",
"es6-promise": "^4.2.6",
"express-middleware-minio": "^3.1.0",
"eslint": "^4.12.0",
"eslint-config-pubsweet": "^0.0.6",
"eslint-plugin-import": "^2.8.0",
"eslint-plugin-jest": "^21.4.0",
"eslint-plugin-jsx-a11y": "^6.0.2",
"eslint-plugin-node": "^5.2.1",
"eslint-plugin-prettier": "^2.3.1",
"eslint-plugin-promise": "^3.6.0",
"eslint-plugin-react": "^7.4.0",
"eslint-plugin-standard": "^3.0.1",
"extract-text-webpack-plugin": "^3.0.0",
"faker": "^4.1.0",
"file-loader": "^1.1.5",
"font-awesome": "^4.7.0",
"form-data": "^2.3.2",
"formik": "^1.3.2",
......@@ -48,10 +71,15 @@
"graphql-type-json": "^0.2.1",
"gunzip-maybe": "^1.4.1",
"history": "^4.7.2",
"html-webpack-plugin": "^2.24.0",
"husky": "^0.14.3",
"isomorphic-fetch": "^2.2.1",
"jest": "^24.5.0",
"joi": "^13.5.2",
"joi-browser": "^10.0.6",
"kue": "^0.11.6",
"libxmljs": "^0.19.5",
"lint-staged": "^4.1.3",
"loadable-components": "^0.3.0",
"md5-file": "^4.0.0",
"mime-types": "^2.1.21",
......@@ -59,7 +87,9 @@
"node-cron": "^2.0.3",
"node-fetch": "^2.2.0",
"node-pre-gyp": "^0.11.0",
"node-sass": "^4.5.3",
"pdfjs-dist": "^2.0.489",
"prettier": "^1.16.3",
"prom-client": "^11.2.1",
"promise-ftp": "^1.3.5",
"prop-types": "^15.5.10",
......@@ -72,10 +102,13 @@
"react-css-modules": "^4.7.7",
"react-dom": "^16.2.0",
"react-dropzone": "^10.1.3",
"react-hot-loader": "^3.1.1",
"react-html-parser": "^2.0.2",
"react-mathjax-preview": "^0.1.10",
"react-redux": "^5.0.2",
"react-router-dom": "^4.2.2",
"react-router-redux": "^5.0.0-alpha.9",
"react-test-renderer": "^16.8.4",
"recompose": "^0.26.0",
"redux": "^3.6.0",
"redux-form": "^7.0.3",
......@@ -84,16 +117,25 @@
"request-promise": "^4.2.4",
"rfr": "^1.2.3",
"rimraf": "^2.6.3",
"sass-loader": "^6.0.6",
"stream-to-array": "^2.3.0",
"string-replace-loader": "^1.3.0",
"style-loader": "^0.19.0",
"stylelint": "^8.2.0",
"stylelint-config-pubsweet": "^0.0.3",
"supertest": "^3.0.0",
"tar": "^4.4.8",
"tar-fs": "^1.16.3",
"tmp": "0.0.33",
"typeface-lora": "^0.0.54",
"typeface-open-sans": "^0.0.54",
"uglifyjs-webpack-plugin": "^1.1.2",
"url-search-params": "^1.1.0",
"waait": "^1.0.2",
"wax-prose-mirror": "^0.0.16",
"webpack": "^3.8.1",
"webpack-dev-middleware": "^1.12.0",
"webpack-hot-middleware": "^2.20.0",
"whatwg-fetch": "^3.0.0",
"winston-daily-rotate-file": "^3.6.0",
"xml2json": "^0.11.2",
......@@ -103,50 +145,7 @@
"xpub-selectors": "^0.1.0",
"xpub-theme": "^0.0.7",
"xslt4node": "^0.3.2",
"yup": "^0.26.6",
"@babel/core": "^7.3.4",
"babel-core": "^6.26.0",
"babel-eslint": "^8.0.2",
"babel-jest": "^24.5.0",
"babel-loader": "^7.1.2",
"babel-preset-env": "^1.6.0",
"babel-preset-es2015": "^6.24.1",
"babel-preset-react": "^6.24.1",
"babel-preset-stage-2": "^6.24.1",
"clean-webpack-plugin": "^0.1.17",
"copy-webpack-plugin": "^4.0.1",
"css-loader": "^0.28.4",
"eslint": "^4.12.0",
"eslint-config-pubsweet": "^0.0.6",
"eslint-plugin-import": "^2.8.0",
"eslint-plugin-jest": "^21.4.0",
"eslint-plugin-jsx-a11y": "^6.0.2",
"eslint-plugin-node": "^5.2.1",
"eslint-plugin-prettier": "^2.3.1",
"eslint-plugin-promise": "^3.6.0",
"eslint-plugin-react": "^7.4.0",
"eslint-plugin-standard": "^3.0.1",
"extract-text-webpack-plugin": "^3.0.0",
"file-loader": "^1.1.5",
"html-webpack-plugin": "^2.24.0",
"husky": "^0.14.3",
"jest": "^24.5.0",
"joi-browser": "^10.0.6",
"lint-staged": "^4.1.3",
"node-sass": "^4.5.3",
"prettier": "^1.16.3",
"react-hot-loader": "^3.1.1",
"react-router-redux": "^5.0.0-alpha.9",
"react-test-renderer": "^16.8.4",
"sass-loader": "^6.0.6",
"string-replace-loader": "^1.3.0",
"style-loader": "^0.19.0",
"stylelint": "^8.2.0",
"stylelint-config-pubsweet": "^0.0.3",
"uglifyjs-webpack-plugin": "^1.1.2",
"webpack": "^3.8.1",
"webpack-dev-middleware": "^1.12.0",
"webpack-hot-middleware": "^2.20.0"
"yup": "^0.26.6"
},
"resolutions": {
"graphql": "^0.13.0"
......
......@@ -9,7 +9,7 @@ const gql = require('graphql-tag')
const fetch = require('node-fetch')
*/
const uuidv4 = require('uuid/v4')
const { minioClient } = require('express-middleware-minio')
const { minioClient } = require('@europepmc/express-middleware-minio')
const Manuscript = require('../xpub-model/entities/manuscript/data-access')
const ManuscriptManager = require('../xpub-model/entities/manuscript/index')
const Journal = require('../xpub-model/entities/journal/data-access')
......
const config = require('config')
const expressMinio = require('express-middleware-minio')
const expressMinio = require('@europepmc/express-middleware-minio')
const rfr = require('rfr')
const FileModel = rfr('server/xpub-model/entities/file/data-access')
......
......@@ -8,7 +8,7 @@ const fetch = require('node-fetch')
const dateFormat = require('dateformat')
const rimraf = require('rimraf')
const { minioClient } = require('express-middleware-minio')
const { minioClient } = require('@europepmc/express-middleware-minio')
module.exports.getManifestFilename = function getManifestFilename(tmpPath) {
return new Promise((resolve, reject) => {
......
const uuidv1 = require('uuid/v1')
const config = require('config')
const logger = require('@pubsweet/logger')
const { minioClient } = require('express-middleware-minio')
const { minioClient } = require('@europepmc/express-middleware-minio')
const { Readable } = require('stream')
const rfr = require('rfr')
......
......@@ -2,7 +2,7 @@ const uuidv1 = require('uuid/v1')
const logger = require('@pubsweet/logger')
const config = require('config')
const rfr = require('rfr')
const { minioClient } = require('express-middleware-minio')
const { minioClient } = require('@europepmc/express-middleware-minio')
const { timer } = require('benmark')
const fs = require('fs')
const http = require('http')
......
......@@ -285,6 +285,17 @@
resolved "https://registry.yarnpkg.com/@emotion/unitless/-/unitless-0.7.3.tgz#6310a047f12d21a1036fb031317219892440416f"
integrity sha512-4zAPlpDEh2VwXswwr/t8xGNDGg8RQiPxtxZ3qQEXyQsBV39ptTdESCjuBvGze1nLMVrxmTIKmnO/nAV8Tqjjzg==
 
"@europepmc/express-middleware-minio@^3.2.5":
version "3.2.5"
resolved "https://registry.yarnpkg.com/@europepmc/express-middleware-minio/-/express-middleware-minio-3.2.5.tgz#42ebc811612965a403646521782e30f0128907dd"
integrity sha512-4JHXQjXVn+GGbAuh4MwGlbUyKCrmDrU3a77kGYK20Ec7GT7Q3/3J3IoXBUIPo7WYneq2EJJi0cvFljxNKBaRyg==
dependencies:
config "^3.0.1"
dotenv "^6.2.0"
formidable "^1.2.1"
minio "^7.0.1"
uuid "^3.2.1"
"@fortawesome/fontawesome-common-types@^0.1.7":
version "0.1.7"
resolved "https://registry.yarnpkg.com/@fortawesome/fontawesome-common-types/-/fontawesome-common-types-0.1.7.tgz#4336c4b06d0b5608ff1215464b66fcf9f4795284"
......@@ -1442,7 +1453,7 @@ async@2.6.1:
dependencies:
lodash "^4.17.10"
 
"async@>=0.4.0 < 2.0.0", async@^1.5.2:
"async@>=0.4.0 < 2.0.0":
version "1.5.2"
resolved "https://registry.yarnpkg.com/async/-/async-1.5.2.tgz#ec6a61ae56480c0c3cb241c95618e20892f9672a"
integrity sha1-7GphrlZIDAw8skHJVhjiCJL5Zyo=
......@@ -1454,6 +1465,11 @@ async@^2.1.2, async@^2.4.1, async@^2.5.0, async@^2.6.1:
dependencies:
lodash "^4.17.11"
 
async@^3.1.0:
version "3.1.0"
resolved "https://registry.yarnpkg.com/async/-/async-3.1.0.tgz#42b3b12ae1b74927b5217d8c0016baaf62463772"
integrity sha512-4vx/aaY6j/j3Lw3fbCHNWP0pPaTCew3F6F3hYyl/tHs/ndmV1q7NW9T5yuJ2XAGwdQrP+6Wu20x06U4APo/iQQ==
async@~0.9.0:
version "0.9.2"
resolved "https://registry.yarnpkg.com/async/-/async-0.9.2.tgz#aea74d5e61c1f899613bf64bda66d4c78f2fd17d"
......@@ -2501,14 +2517,12 @@ bl@^1.0.0:
readable-stream "^2.3.5"
safe-buffer "^5.1.1"
 
block-stream2@^1.0.0:
version "1.1.0"
resolved "https://registry.yarnpkg.com/block-stream2/-/block-stream2-1.1.0.tgz#c738e3a91ba977ebb5e1fef431e13ca11d8639e2"
integrity sha1-xzjjqRupd+u14f70MeE8oR2GOeI=
block-stream2@^2.0.0:
version "2.0.0"
resolved "https://registry.yarnpkg.com/block-stream2/-/block-stream2-2.0.0.tgz#680b9d357ca8b9d5637f4ec8a41fb5968029108f"
integrity sha512-1oI+RHHUEo64xomy1ozLgVJetFlHkIfQfJzTBQrj6xWnEMEPooeo2fZoqFjp0yzfHMBrgxwgh70tKp6T17+i3g==
dependencies:
defined "^1.0.0"
inherits "^2.0.1"
readable-stream "^2.0.4"
readable-stream "^3.4.0"
 
block-stream@*:
version "0.0.9"
......@@ -3465,7 +3479,7 @@ concat-map@0.0.1:
resolved "https://registry.yarnpkg.com/concat-map/-/concat-map-0.0.1.tgz#d8a96bd77fd68df7793a73036a3ba0d5405d477b"
integrity sha1-2Klr13/Wjfd5OnMDajug1UBdR3s=
 
concat-stream@^1.4.8, concat-stream@^1.5.0, concat-stream@^1.5.2, concat-stream@^1.6.0:
concat-stream@^1.5.0, concat-stream@^1.5.2, concat-stream@^1.6.0:
version "1.6.2"
resolved "https://registry.yarnpkg.com/concat-stream/-/concat-stream-1.6.2.tgz#904bdf194cd3122fc675c77fc4ac3d4ff0fd1a34"
integrity sha512-27HBghJxjiZtIk3Ycvn/4kbJk/1uZuJFfuPEns6LaEvpvG1f0hTea8lilrouyo9mVc2GWdcEZ8OLoGmSADlrCw==
......@@ -4395,7 +4409,7 @@ dotenv@^4.0.0:
resolved "https://registry.yarnpkg.com/dotenv/-/dotenv-4.0.0.tgz#864ef1379aced55ce6f95debecdce179f7a0cd1d"
integrity sha1-hk7xN5rO1Vzm+V3r7NzhefegzR0=
 
dotenv@^6.0.0:
dotenv@^6.0.0, dotenv@^6.2.0:
version "6.2.0"
resolved "https://registry.yarnpkg.com/dotenv/-/dotenv-6.2.0.tgz#941c0410535d942c8becf28d3f357dbd9d476064"
integrity sha512-HygQCKUBSFl8wKQZBSemMywRWcEDNidvNbjGVyZu3nbZ8qq9ubiPoGLMdRDpfSrpkkm9BXYFkpKxxFX38o/76w==
......@@ -4638,11 +4652,6 @@ es5-ext@^0.10.14, es5-ext@^0.10.35, es5-ext@^0.10.9, es5-ext@~0.10.14:
es6-symbol "~3.1.1"
next-tick "^1.0.0"
 
es6-error@^2.0.2:
version "2.1.1"
resolved "https://registry.yarnpkg.com/es6-error/-/es6-error-2.1.1.tgz#91384301ec5ed1c9a7247d1128247216f03547cd"
integrity sha1-kThDAexe0cmnJH0RKCRyFvA1R80=
es6-error@^4.1.1:
version "4.1.1"
resolved "https://registry.yarnpkg.com/es6-error/-/es6-error-4.1.1.tgz#9e3af407459deed47e9a91f9b885a84eb05c561d"
......@@ -5213,17 +5222,6 @@ express-fileupload@v1.1.1-alpha.2:
md5 "^2.2.1"
streamifier "^0.1.1"
 
express-middleware-minio@^3.1.0:
version "3.1.0"
resolved "https://registry.yarnpkg.com/express-middleware-minio/-/express-middleware-minio-3.1.0.tgz#6d32f36ddf83bd181326ef0007abf49292fdac10"
integrity sha512-Se4k5K0EnB98l71RaqUDf9a8PsfsemcDF3R8uTbtkpEuz62iRRLqiVDR++Vad80qmIZR1Oli/f81qj2SPs2nJQ==
dependencies:
config "^3.0.1"
dotenv "^6.0.0"
formidable "^1.2.1"
minio "^7.0.1"
uuid "^3.2.1"
express@^4.12.2, express@^4.15.3, express@^4.16.1:
version "4.16.4"
resolved "https://registry.yarnpkg.com/express/-/express-4.16.4.tgz#fddef61926109e24c515ea97fd2f1bdbf62df12e"
......@@ -8451,11 +8449,16 @@ lodash.uniq@^4.5.0:
resolved "https://registry.yarnpkg.com/lodash.uniq/-/lodash.uniq-4.5.0.tgz#d0225373aeb652adc1bc82e4945339a842754773"
integrity sha1-0CJTc662Uq3BvILklFM5qEJ1R3M=
 
lodash@4.17.11, lodash@^4, lodash@^4.0.0, lodash@^4.14.2, lodash@^4.15.0, lodash@^4.16.6, lodash@^4.17.10, lodash@^4.17.11, lodash@^4.17.3, lodash@^4.17.4, lodash@^4.2.0, lodash@^4.2.1, lodash@^4.3.0, lodash@^4.6.1, lodash@~4.17.10:
lodash@4.17.11, lodash@^4, lodash@^4.0.0, lodash@^4.15.0, lodash@^4.16.6, lodash@^4.17.10, lodash@^4.17.11, lodash@^4.17.3, lodash@^4.17.4, lodash@^4.2.0, lodash@^4.2.1, lodash@^4.3.0, lodash@^4.6.1, lodash@~4.17.10:
version "4.17.11"
resolved "https://registry.yarnpkg.com/lodash/-/lodash-4.17.11.tgz#b39ea6229ef607ecd89e2c8df12536891cac9b8d"
integrity sha512-cQKh8igo5QUhZ7lg38DYWAxMvjSAKG0A8wGSVimP07SIUEK2UO+arSRKbRZWtelMtN5V0Hkwh5ryOto/SshYIg==
 
lodash@^4.14.2:
version "4.17.15"
resolved "https://registry.yarnpkg.com/lodash/-/lodash-4.17.15.tgz#b447f6670a0455bbfeedd11392eff330ea097548"
integrity sha512-8xOcRHvCjnocdS5cpwXQXVzmmh5e5+saE2QGoeQmbKmRS6J3VQppPOIt0MnmE+4xlZoumy0GPG0D0MVIQbNA1A==
log-symbols@^1.0.2:
version "1.0.2"
resolved "https://registry.yarnpkg.com/log-symbols/-/log-symbols-1.0.2.tgz#376ff7b58ea3086a0f09facc74617eca501e1a18"
......@@ -8780,18 +8783,30 @@ mime-db@1.40.0:
resolved "https://registry.yarnpkg.com/mime-db/-/mime-db-1.40.0.tgz#a65057e998db090f732a68f6c276d387d4126c32"
integrity sha512-jYdeOMPy9vnxEqFRRo6ZvTZ8d9oPb+k18PKoYNYUe2stVEBPPwsln/qWzdbmaIvnhZ9v2P+CuecK+fpUfsV2mA==
 
mime-db@1.42.0:
version "1.42.0"
resolved "https://registry.yarnpkg.com/mime-db/-/mime-db-1.42.0.tgz#3e252907b4c7adb906597b4b65636272cf9e7bac"
integrity sha512-UbfJCR4UAVRNgMpfImz05smAXK7+c+ZntjaA26ANtkXLlOe947Aag5zdIcKQULAiF9Cq4WxBi9jUs5zkA84bYQ==
mime-db@^1.28.0, mime-db@~1.38.0:
version "1.38.0"
resolved "https://registry.yarnpkg.com/mime-db/-/mime-db-1.38.0.tgz#1a2aab16da9eb167b49c6e4df2d9c68d63d8e2ad"
integrity sha512-bqVioMFFzc2awcdJZIzR3HjZFX20QhilVS7hytkKrv7xFAn8bM1gzc/FOX2awLISvWe0PV8ptFKcon+wZ5qYkg==
 
mime-types@^2.1.12, mime-types@^2.1.14, mime-types@^2.1.21, mime-types@~2.1.18, mime-types@~2.1.19:
mime-types@^2.1.12, mime-types@^2.1.21, mime-types@~2.1.18, mime-types@~2.1.19:
version "2.1.22"
resolved "https://registry.yarnpkg.com/mime-types/-/mime-types-2.1.22.tgz#fe6b355a190926ab7698c9a0556a11199b2199bd"
integrity sha512-aGl6TZGnhm/li6F7yx82bJiBZwgiEa4Hf6CNr8YO+r5UHr53tSTYZb102zyU50DOWWKeOv0uQLRL0/9EiKWCog==
dependencies:
mime-db "~1.38.0"
 
mime-types@^2.1.14:
version "2.1.25"
resolved "https://registry.yarnpkg.com/mime-types/-/mime-types-2.1.25.tgz#39772d46621f93e2a80a856c53b86a62156a6437"
integrity sha512-5KhStqB5xpTAeGqKBAMgwaYMnQik7teQN4IAzC7npDv6kzeU6prfkR67bc87J1kWMPGkoaZSq1npmexMgkmEVg==
dependencies:
mime-db "1.42.0"
mime-types@~2.1.24:
version "2.1.24"
resolved "https://registry.yarnpkg.com/mime-types/-/mime-types-2.1.24.tgz#b6f8d0b3e951efb77dedeca194cff6d16f676f81"
......@@ -8877,21 +8892,19 @@ minimist@~0.0.1:
integrity sha1-3j+YVD2/lggr5IrRoMfNqDYwHc8=
 
minio@^7.0.1:
version "7.0.5"
resolved "https://registry.yarnpkg.com/minio/-/minio-7.0.5.tgz#2f726036f004e6441799cea8e923a6a3835715f2"
integrity sha512-8ElURLlaiV1sGCE5fn9V7zhqYnvfUsntwg6lCR3OPzShak35dpCRKZFY3kdA7B1faTMGdN9jFMMIJ5jdWGEw4g==
dependencies:
async "^1.5.2"
block-stream2 "^1.0.0"
concat-stream "^1.4.8"
es6-error "^2.0.2"
version "7.0.12"
resolved "https://registry.yarnpkg.com/minio/-/minio-7.0.12.tgz#5dca6daefd5efa94a61c08dc6a2cce44517f3743"
integrity sha512-mTa8bc2X1vcKwbzvNMNk/DHkuSrlfjlG3aA8IA1qihlH73XbwiloX/6skCabmDvrmmt6cx6pytaBJZmp4OMwnw==
dependencies:
async "^3.1.0"
block-stream2 "^2.0.0"
es6-error "^4.1.1"
json-stream "^1.0.0"
lodash "^4.14.2"
mime-types "^2.1.14"
mkdirp "^0.5.1"
querystring "0.2.0"
through2 "^0.6.5"
uuid "^3.1.0"
through2 "^3.0.1"
xml "^1.0.0"
xml2js "^0.4.15"
 
......@@ -11892,7 +11905,7 @@ read@1.0.x:
dependencies:
mute-stream "~0.0.4"
 
"readable-stream@1 || 2", readable-stream@^2.0.0, readable-stream@^2.0.1, readable-stream@^2.0.2, readable-stream@^2.0.4, readable-stream@^2.0.6, readable-stream@^2.1.5, readable-stream@^2.2.2, readable-stream@^2.3.0, readable-stream@^2.3.3, readable-stream@^2.3.5, readable-stream@^2.3.6, readable-stream@~2.3.6:
"readable-stream@1 || 2", readable-stream@^2.0.0, readable-stream@^2.0.1, readable-stream@^2.0.2, readable-stream@^2.0.6, readable-stream@^2.1.5, readable-stream@^2.2.2, readable-stream@^2.3.0, readable-stream@^2.3.3, readable-stream@^2.3.5, readable-stream@^2.3.6, readable-stream@~2.3.6:
version "2.3.6"
resolved "https://registry.yarnpkg.com/readable-stream/-/readable-stream-2.3.6.tgz#b11c27d88b8ff1fbe070643cf94b0c79ae1b0aaf"
integrity sha512-tQtKA9WIAhBF3+VLAseyMqZeBjW0AHJoxOtYqSUZNJxauErmLbVm2FW1y+J/YA9dUrAC39ITejlZWhVIwawkKw==
......@@ -11915,15 +11928,14 @@ readable-stream@1.1.x, readable-stream@~1.1.9:
isarray "0.0.1"
string_decoder "~0.10.x"
 
"readable-stream@>=1.0.33-1 <1.1.0-0", readable-stream@~1.0.17:
version "1.0.34"
resolved "https://registry.yarnpkg.com/readable-stream/-/readable-stream-1.0.34.tgz#125820e34bc842d2f2aaafafe4c2916ee32c157c"
integrity sha1-Elgg40vIQtLyqq+v5MKRbuMsFXw=
"readable-stream@2 || 3", readable-stream@^3.4.0:
version "3.4.0"
resolved "https://registry.yarnpkg.com/readable-stream/-/readable-stream-3.4.0.tgz#a51c26754658e0a3c21dbf59163bd45ba6f447fc"
integrity sha512-jItXPLmrSR8jmTRmRWJXCnGJsfy85mB3Wd/uINMXA65yrnFo0cPClFIUWzo2najVNSl+mx7/4W8ttlLWJe99pQ==
dependencies:
core-util-is "~1.0.0"
inherits "~2.0.1"
isarray "0.0.1"
string_decoder "~0.10.x"
inherits "^2.0.3"
string_decoder "^1.1.1"
util-deprecate "^1.0.1"
 
readable-stream@^3.1.1:
version "3.2.0"
......@@ -11934,6 +11946,16 @@ readable-stream@^3.1.1:
string_decoder "^1.1.1"
util-deprecate "^1.0.1"
 
readable-stream@~1.0.17:
version "1.0.34"
resolved "https://registry.yarnpkg.com/readable-stream/-/readable-stream-1.0.34.tgz#125820e34bc842d2f2aaafafe4c2916ee32c157c"
integrity sha1-Elgg40vIQtLyqq+v5MKRbuMsFXw=
dependencies:
core-util-is "~1.0.0"
inherits "~2.0.1"
isarray "0.0.1"
string_decoder "~0.10.x"
readdirp@^2.0.0, readdirp@^2.2.1:
version "2.2.1"
resolved "https://registry.yarnpkg.com/readdirp/-/readdirp-2.2.1.tgz#0e87622a3325aa33e892285caf8b4e846529a525"
......@@ -13647,14 +13669,6 @@ throat@^4.0.0:
resolved "https://registry.yarnpkg.com/throat/-/throat-4.1.0.tgz#89037cbc92c56ab18926e6ba4cbb200e15672a6a"
integrity sha1-iQN8vJLFarGJJua6TLsgDhVnKmo=
 
through2@^0.6.5:
version "0.6.5"
resolved "https://registry.yarnpkg.com/through2/-/through2-0.6.5.tgz#41ab9c67b29d57209071410e1d7a7a968cd3ad48"
integrity sha1-QaucZ7KdVyCQcUEOHXp6lozTrUg=
dependencies:
readable-stream ">=1.0.33-1 <1.1.0-0"
xtend ">=4.0.0 <4.1.0-0"
through2@^2.0.0, through2@^2.0.3:
version "2.0.5"
resolved "https://registry.yarnpkg.com/through2/-/through2-2.0.5.tgz#01c1e39eb31d07cb7d03a96a70823260b23132cd"
......@@ -13663,6 +13677,13 @@ through2@^2.0.0, through2@^2.0.3:
readable-stream "~2.3.6"
xtend "~4.0.1"
 
through2@^3.0.1:
version "3.0.1"
resolved "https://registry.yarnpkg.com/through2/-/through2-3.0.1.tgz#39276e713c3302edf9e388dd9c812dd3b825bd5a"
integrity sha512-M96dvTalPT3YbYLaKaCuwu+j06D/8Jfib0o/PxbVt6Amhv3dUAtW6rTV1jPgJSBG83I/e04Y6xkVdVhSRhi0ww==
dependencies:
readable-stream "2 || 3"
through2@~0.4.0:
version "0.4.2"
resolved "https://registry.yarnpkg.com/through2/-/through2-0.4.2.tgz#dbf5866031151ec8352bb6c4db64a2292a840b9b"
......@@ -14247,7 +14268,7 @@ util-deprecate@^1.0.1, util-deprecate@~1.0.1:
resolved "https://registry.yarnpkg.com/util-deprecate/-/util-deprecate-1.0.2.tgz#450d4dc9fa70de732762fbd2d4a28981419a0ccf"
integrity sha1-RQ1Nyfpw3nMnYvvS1KKJgUGaDM8=
 
util.promisify@^1.0.0:
util.promisify@^1.0.0, util.promisify@~1.0.0:
version "1.0.0"
resolved "https://registry.yarnpkg.com/util.promisify/-/util.promisify-1.0.0.tgz#440f7165a459c9a16dc145eb8e72f35687097030"
integrity sha512-i+6qA2MPhvoKLuxnJNpXAGhg7HphQOSUq2LKMZD0m15EiskXUkMvKdF4Uui0WYeCUGea+o2cw/ZuwehtfsrNkA==
......@@ -14790,7 +14811,7 @@ xml-name-validator@^3.0.0:
resolved "https://registry.yarnpkg.com/xml-name-validator/-/xml-name-validator-3.0.0.tgz#6ae73e06de4d8c6e47f9fb181f78d648ad457c6a"
integrity sha512-A5CUptxDsvxKJEU3yO6DuWBSJz/qizqzJKOMIfUJHETbBw/sFaDxgd6fxm1ewUaM0jZ444Fc5vC5ROYurg/4Pw==
 
xml2js@0.4.19, xml2js@^0.4.15:
xml2js@0.4.19:
version "0.4.19"
resolved "https://registry.yarnpkg.com/xml2js/-/xml2js-0.4.19.tgz#686c20f213209e94abf0d1bcf1efaa291c7827a7"
integrity sha512-esZnJZJOiJR9wWKMyuvSE1y6Dq5LCuJanqhxslH2bxM6duahNZ+HMpCLhBQGZkbX6xRf8x1Y2eJlgt2q3qo49Q==
......@@ -14798,6 +14819,15 @@ xml2js@0.4.19, xml2js@^0.4.15:
sax ">=0.6.0"
xmlbuilder "~9.0.1"
 
xml2js@^0.4.15:
version "0.4.22"
resolved "https://registry.yarnpkg.com/xml2js/-/xml2js-0.4.22.tgz#4fa2d846ec803237de86f30aa9b5f70b6600de02"
integrity sha512-MWTbxAQqclRSTnehWWe5nMKzI3VmJ8ltiJEco8akcC6j3miOhjjfzKum5sId+CWhfxdOs/1xauYr8/ZDBtQiRw==
dependencies:
sax ">=0.6.0"
util.promisify "~1.0.0"
xmlbuilder "~11.0.0"
xml2json@^0.11.2:
version "0.11.2"
resolved "https://registry.yarnpkg.com/xml2json/-/xml2json-0.11.2.tgz#70ddd234fd7818312cc58455cab8457b5bcc7c52"
......@@ -14812,6 +14842,11 @@ xml@^1.0.0:
resolved "https://registry.yarnpkg.com/xml/-/xml-1.0.1.tgz#78ba72020029c5bc87b8a81a3cfcd74b4a2fc1e5"
integrity sha1-eLpyAgApxbyHuKgaPPzXS0ovweU=
 
xmlbuilder@~11.0.0:
version "11.0.1"
resolved "https://registry.yarnpkg.com/xmlbuilder/-/xmlbuilder-11.0.1.tgz#be9bae1c8a046e76b31127726347d0ad7002beb3"
integrity sha512-fDlsI/kFEx7gLvbecc0/ohLG50fugQp8ryHzMTuW9vSa1GJ0XYWKnhsUx7oie3G98+r56aTQIUB4kht42R3JvA==
xmlbuilder@~9.0.1:
version "9.0.7"
resolved "https://registry.yarnpkg.com/xmlbuilder/-/xmlbuilder-9.0.7.tgz#132ee63d2ec5565c557e20f4c22df9aca686b10d"
......@@ -14872,7 +14907,7 @@ xslt4node@^0.3.2:
async ">=0.4.0 < 2.0.0"
java ">=0.3.1"
 
"xtend@>=4.0.0 <4.1.0-0", xtend@^4.0.0, xtend@^4.0.1, xtend@~4.0.0, xtend@~4.0.1:
xtend@^4.0.0, xtend@^4.0.1, xtend@~4.0.0, xtend@~4.0.1:
version "4.0.1"
resolved "https://registry.yarnpkg.com/xtend/-/xtend-4.0.1.tgz#a5c6d532be656e23db820efb943a1f04998d63af"
integrity sha1-pcbVMr5lbiPbgg77lDofBJmNY68=
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment