Commit bb40334e authored by Jure's avatar Jure

Merge branch 'react_upgrade' into 'master'

Upgrade pubsweet-client & React to version 16.2.0

See merge request !117
parents 9cb0ef90 33f9405d
Pipeline #4852 passed with stages
in 4 minutes and 5 seconds
......@@ -9,22 +9,22 @@
"dist"
],
"dependencies": {
"@pubsweet/ui": "^2.0.0",
"classnames": "^2.2.5",
"prop-types": "^15.5.10",
"react": "^15.6.1",
"react-dom": "^15.6.1",
"react": "^16.2.0",
"react-dom": "^16.2.0",
"react-redux": "^5.0.2",
"react-router-dom": "^4.2.2",
"recompose": "^0.26.0",
"redux": "^3.6.0",
"xpub-bootstrap": "^0.0.2",
"xpub-journal": "^0.0.2",
"@pubsweet/ui": "^0.2.0"
"xpub-journal": "^0.0.2"
},
"peerDependencies": {
"prop-types": "^15.5.10",
"react": "^15.6.1",
"react-dom": "^15.6.1",
"react": "^16.2.0",
"react-dom": "^16.2.0",
"react-redux": "^5.0.2",
"react-router-dom": "^4.2.2"
}
......
......@@ -9,14 +9,14 @@
"dist"
],
"dependencies": {
"@pubsweet/ui": "^0.1.1",
"@pubsweet/ui": "^2.0.0",
"classnames": "^2.2.5",
"lodash": "^4.17.4",
"prop-types": "^15.5.10",
"pubsweet-client": "^1.1.4",
"pubsweet-component-ink-frontend": "^0.2.3",
"react": "^15.6.1",
"react-dom": "^15.6.1",
"pubsweet-client": "^2.1.0",
"pubsweet-component-ink-frontend": "^1.0.0",
"react": "^16.2.0",
"react-dom": "^16.2.0",
"react-dropzone": "^4.1.2",
"react-moment": "^0.6.1",
"react-redux": "^5.0.2",
......@@ -26,7 +26,6 @@
"xpub-connect": "^0.0.2",
"xpub-journal": "^0.0.2",
"xpub-selectors": "^0.0.2",
"@pubsweet/ui": "^0.2.0",
"xpub-upload": "^0.0.2"
},
"devDependencies": {
......@@ -37,14 +36,14 @@
"babel-preset-stage-2": "^6.24.1",
"css-loader": "^0.28.4",
"enzyme": "^3.3.0",
"enzyme-adapter-react-15": "^1.0.5",
"enzyme-adapter-react-16": "^1.1.1",
"faker": "^4.1.0",
"file-loader": "^1.1.5",
"identity-obj-proxy": "^3.0.0",
"jest": "^22.1.1",
"node-sass": "^4.5.3",
"react-styleguidist": "^6.0.8",
"react-test-renderer": "^15.6.2",
"react-styleguidist": "^6.2.5",
"react-test-renderer": "^16.2.0",
"redux-mock-store": "^1.4.0",
"sass-loader": "^6.0.6",
"style-loader": "^0.19.0",
......
import React from 'react'
import Enzyme, { shallow } from 'enzyme'
import Adapter from 'enzyme-adapter-react-15'
import Adapter from 'enzyme-adapter-react-16'
import Dashboard from './Dashboard'
......
......@@ -5,7 +5,7 @@ import { combineReducers } from 'redux'
import configureMockStore from 'redux-mock-store'
import thunk from 'redux-thunk'
import Enzyme, { mount } from 'enzyme'
import Adapter from 'enzyme-adapter-react-15'
import Adapter from 'enzyme-adapter-react-16'
import { reducers } from 'pubsweet-client'
import conversion from '../redux/conversion'
......
......@@ -7,15 +7,15 @@
],
"main": "src",
"dependencies": {
"wax-editor-react": "^0.1.8",
"wax-editor-react": "^0.1.10",
"xpub-connect": "^0.0.2",
"xpub-selectors": "^0.0.2"
},
"peerDependencies": {
"prop-types": "^15.5.10",
"pubsweet-client": "^1.1.4",
"react": "^15.6.1",
"react-dom": "^15.6.1",
"pubsweet-client": "^2.1.0",
"react": "^16.2.0",
"react-dom": "^16.2.0",
"react-redux": "^5.0.2",
"react-router-dom": "^4.2.2",
"recompose": "^0.26.0"
......@@ -30,19 +30,19 @@
"faker": "^4.1.0",
"file-loader": "^1.1.5",
"node-sass": "^4.5.3",
"prop-types": "^15.5.10",
"pubsweet-client": "^2.1.0",
"react": "^16.2.0",
"react-dom": "^16.2.0",
"react-redux": "^5.0.2",
"react-router-dom": "^4.2.2",
"react-styleguidist": "^6.2.5",
"recompose": "^0.26.0",
"rimraf": "^2.6.1",
"react-styleguidist": "^6.0.8",
"sass-loader": "^6.0.6",
"style-loader": "^0.19.0",
"webpack": "^3.8.1",
"webpack-node-externals": "^1.6.0",
"prop-types": "^15.5.10",
"pubsweet-client": "^1.1.4",
"react": "^15.6.1",
"react-dom": "^15.6.1",
"react-redux": "^5.0.2",
"react-router-dom": "^4.2.2",
"xpub-styleguide": "^0.0.2"
},
"scripts": {
......
......@@ -9,13 +9,14 @@
"dist"
],
"dependencies": {
"@pubsweet/ui": "^2.0.0",
"classnames": "^2.2.5",
"lodash": "^4.17.4",
"moment": "^2.18.1",
"prop-types": "^15.5.10",
"pubsweet-client": "^1.1.4",
"react": "^15.6.1",
"react-dom": "^15.6.1",
"pubsweet-client": "^2.1.0",
"react": "^16.2.0",
"react-dom": "^16.2.0",
"react-moment": "^0.6.1",
"react-redux": "^5.0.2",
"react-router-dom": "^4.2.2",
......@@ -30,7 +31,6 @@
"xpub-edit": "^0.0.2",
"xpub-journal": "^0.0.2",
"xpub-selectors": "^0.0.2",
"@pubsweet/ui": "^0.2.0",
"xpub-upload": "^0.0.2",
"xpub-validators": "^0.0.2"
},
......@@ -44,7 +44,7 @@
"faker": "^4.1.0",
"file-loader": "^1.1.5",
"node-sass": "^4.5.3",
"react-styleguidist": "^6.0.8",
"react-styleguidist": "^6.2.5",
"sass-loader": "^6.0.6",
"style-loader": "^0.19.0",
"webpack": "^3.8.1",
......@@ -53,9 +53,9 @@
},
"peerDependencies": {
"prop-types": "^15.5.10",
"pubsweet-client": "^1.1.4",
"react": "^15.6.1",
"react-dom": "^15.6.1",
"pubsweet-client": "^2.1.0",
"react": "^16.2.0",
"react-dom": "^16.2.0",
"react-redux": "^5.0.2",
"react-router-dom": "^4.2.2"
},
......
......@@ -9,12 +9,13 @@
"dist"
],
"dependencies": {
"@pubsweet/ui": "^2.0.0",
"classnames": "^2.2.5",
"lodash": "^4.17.4",
"prop-types": "^15.5.10",
"pubsweet-client": "^1.1.4",
"react": "^15.6.1",
"react-dom": "^15.6.1",
"pubsweet-client": "^2.1.0",
"react": "^16.2.0",
"react-dom": "^16.2.0",
"react-redux": "^5.0.2",
"react-router-dom": "^4.2.2",
"recompose": "^0.26.0",
......@@ -25,7 +26,6 @@
"xpub-edit": "^0.0.2",
"xpub-journal": "^0.0.2",
"xpub-selectors": "^0.0.2",
"@pubsweet/ui": "^0.2.0",
"xpub-upload": "^0.0.2",
"xpub-validators": "^0.0.2"
},
......@@ -39,7 +39,7 @@
"faker": "^4.1.0",
"file-loader": "^1.1.5",
"node-sass": "^4.5.3",
"react-styleguidist": "^6.0.8",
"react-styleguidist": "^6.2.5",
"sass-loader": "^6.0.6",
"style-loader": "^0.19.0",
"webpack": "^3.8.1",
......@@ -48,9 +48,9 @@
},
"peerDependencies": {
"prop-types": "^15.5.10",
"pubsweet-client": "^1.1.4",
"react": "^15.6.1",
"react-dom": "^15.6.1",
"pubsweet-client": "^2.1.0",
"react": "^16.2.0",
"react-dom": "^16.2.0",
"react-redux": "^5.0.2",
"react-router-dom": "^4.2.2"
},
......
......@@ -8,7 +8,7 @@
"url": "https://gitlab.coko.foundation/xpub/xpub"
},
"dependencies": {
"@pubsweet/ui": "^0.2.0",
"@pubsweet/ui": "^2.0.0",
"babel-core": "^6.26.0",
"config": "^1.26.2",
"font-awesome": "^4.7.0",
......@@ -19,19 +19,19 @@
"moment": "^2.18.1",
"prop-types": "^15.5.10",
"pubsweet": "^1.1.1",
"pubsweet-client": "^1.1.4",
"pubsweet-client": "^2.1.0",
"pubsweet-component-ink-backend": "^0.1.1",
"pubsweet-component-ink-frontend": "^0.2.3",
"pubsweet-component-login":"^0.6.0",
"pubsweet-component-signup": "^0.5.0",
"pubsweet-component-ink-frontend": "^1.0.0",
"pubsweet-component-login": "^1.0.1",
"pubsweet-component-signup": "^1.0.0",
"pubsweet-component-xpub-app": "^0.0.2",
"pubsweet-component-xpub-dashboard": "^0.0.2",
"pubsweet-component-xpub-manuscript": "^0.0.2",
"pubsweet-component-xpub-review": "^0.0.2",
"pubsweet-component-xpub-submit": "^0.0.2",
"pubsweet-server": "^1.0.1",
"react": "^15.6.1",
"react-dom": "^15.6.1",
"react": "^16.2.0",
"react-dom": "^16.2.0",
"react-router-dom": "^4.2.2",
"recompose": "^0.26.0",
"redux": "^3.6.0",
......
......@@ -9,16 +9,16 @@
"dist"
],
"dependencies": {
"react": "^15.6.1",
"react-dom": "^15.6.1",
"react": "^16.2.0",
"react-dom": "^16.2.0",
"react-redux": "^5.0.2",
"react-router-dom": "^4.2.2",
"recompose": "^0.26.0",
"redux": "^3.6.0"
},
"peerDependencies": {
"react": "^15.6.1",
"react-dom": "^15.6.1",
"react": "^16.2.0",
"react-dom": "^16.2.0",
"react-redux": "^5.0.2",
"react-router-dom": "^4.2.2",
"redux": "^3.6.0"
......
......@@ -16,8 +16,8 @@
"prosemirror-model": "^1.0.0",
"prosemirror-state": "^1.0.1",
"prosemirror-view": "^1.0.0",
"react": "^15.6.1",
"react-dom": "^15.6.1"
"react": "^16.2.0",
"react-dom": "^16.2.0"
},
"devDependencies": {
"babel-core": "^6.26.0",
......@@ -29,7 +29,7 @@
"faker": "^4.1.0",
"file-loader": "^1.1.5",
"node-sass": "^4.5.3",
"react-styleguidist": "^6.0.8",
"react-styleguidist": "^6.2.5",
"sass-loader": "^6.0.6",
"style-loader": "^0.19.0",
"webpack": "^3.8.1",
......
......@@ -10,13 +10,13 @@
],
"dependencies": {
"prop-types": "^15.5.10",
"react": "^15.6.1",
"react-dom": "^15.6.1",
"react": "^16.2.0",
"react-dom": "^16.2.0",
"recompose": "^0.26.0"
},
"peerDependencies": {
"prop-types": "^15.5.10",
"react": "^15.6.1",
"react-dom": "^15.6.1"
"react": "^16.2.0",
"react-dom": "^16.2.0"
}
}
......@@ -7,9 +7,9 @@
],
"main": "src",
"dependencies": {
"@pubsweet/styleguide": "^0.1.1",
"react": "^15.6.1",
"react-dom": "^15.6.1",
"@pubsweet/styleguide": "^1.0.0",
"react": "^16.2.0",
"react-dom": "^16.2.0",
"react-redux": "^5.0.2",
"react-router-dom": "^4.2.2",
"recompose": "^0.26.0",
......
......@@ -5,7 +5,7 @@
"main": "src",
"license": "MIT",
"dependencies": {
"@pubsweet/theme": "^0.1.1",
"@pubsweet/theme": "^0.1.3",
"cokourier-prime-sans": "git+https://gitlab.coko.foundation/julientaq/cokourier-sans-prime.git",
"typeface-fira-mono": "^0.0.43",
"typeface-fira-sans": "^0.0.43",
......
......@@ -9,17 +9,17 @@
"dist"
],
"dependencies": {
"pubsweet-client": "^1.1.4",
"react": "^15.6.1",
"react-dom": "^15.6.1",
"pubsweet-client": "^2.1.0",
"react": "^16.2.0",
"react-dom": "^16.2.0",
"react-redux": "^5.0.2",
"react-router-dom": "^4.2.2",
"recompose": "^0.26.0",
"redux": "^3.6.0"
},
"peerDependencies": {
"react": "^15.6.1",
"react-dom": "^15.6.1",
"react": "^16.2.0",
"react-dom": "^16.2.0",
"react-redux": "^5.0.2",
"react-router-dom": "^4.2.2",
"redux": "^3.6.0"
......
This source diff could not be displayed because it is too large. You can view the blob instead.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment